What are the Compatible Devices & OS?

Windows:

  • Windows 7, Windows 8, Windows 8.1, Windows 10 are all supported. 
  • Windows XP and Vista's final VSee version is Version 3.6 (29750).
  • We do support Windows XP SP3 but please do keep in mind official support for this platform has been stopped by Microsoft.
  • 2GHz single-core CPU for up to 3-way calls; dual-core CPU for larger meetings.
  • i5 or i7 CPU is recommended for group video calls
  • Windows Surface Pro 3 and later are supported. Any Windows RT versions are not supported.

Mac:

  • Mac App Store version: OS X 10.10 up to the latest

    *Please click here if you need VSee for OS X 10.9 and below.

iOS:

  • iOS 9 or later
  • iPad 2 or newer
  • iPad Mini 1st and 2nd generation
  • iPhone 4s or newer

Android:

  • Android 4.1 Jelly Bean or later
  • NEON compatible ARM processor
  • Dual core CPU
  • Recommendations: Samsung Galaxy S3, Galaxy S4, Galaxy S5, Galaxy S6, HTC One, HTC One M8, Nexus 5, Samsung Tab 4 10.1

*Not supported:

  • Devices using Atom processor (e.g. Dell Venue 8)
  • Devices without rear camera (corrected in upcoming 3.4.1 release)
  • Problem with camera or high video delay: Samsung Mini S3, Nexus 4, LG G3

 Linux and Chromebook

 Unfortunately, we currently do not have plans for a Linux version and Chromebook.

 

Have more questions? Submit a request

0 Comments

Article is closed for comments.